Главная » Статьи » Студентам » Имитационное моделирование

Лабораторная работа. Задание 1
Задание
  Время между последовательными прибытиями покупателей в магазин равномерно распределяется в интервале от 1 до 20 минут. Для 50% покупателей время обслуживания составляет 8 минут, в то время как для остальных 50% это время составляет 14 минут.
  Предложите подходящий генератор случайных чисел. Используя метод дискретно-событийного моделирования, имитируйте один рабочий день магазина (в MS Excel).
  Определите суммарное время ожидания покупателей и время простоя системы.
 Решение

А
B C D E F G
1
Покупа-
тель
Время между прибытиями покупателей, минут
Момент прибытия клиента, минута Время обслужи-вания, минут Конец обслужи-вания, минута Время нахождения в магазине, минут Время ожидания в очереди, минут
2
1
0 0 8 8 8 0
3 2 2 2 14 22 20 6
4 3 16 18 14 36 18 4
5 4 8 26 8 44 18 10
6

5

1 27 14 58 31 17
...
... ... ... ... ... ... ...
23 22 1 214 8 240 26 18
24        

 

437 213
B2=0;    B3=СЛУЧМЕЖДУ(1; 20);   C2=0;        C3=C2+B3;    D2=СЛУЧМЕЖДУ(0; 1)*6+8 ;
E2=D2;  E3=D3+МАКС(E2;C3);      F2=E2-C2;  G2=F2-D2.

Если выразить решение через формат времени "часы:минуты", то имеет следующий вид

t11=0;  t1i=СЛУЧМЕЖДУ(1; 20);   t2i=СЛУЧМЕЖДУ(0; 1)*6+8
   Текущее модельное время (CMT):
CMTi=CMTi-1+t1i.
   Для удобства представим CMT в виде: целая часть отображает часы, тогда как дробная – минуты. Процедура перерасчета осуществляется по формуле
t3i = 4*ОТБР(CMTi/60)+0,01*CMTi.
   Функция ОТБР усекает число до целого, отбрасывая дробную часть числа, так что остается целое число.
ts1=0; tsi=МАКС(tfi-1; t3i);
tfi=ЕСЛИ(((tsi+0,4*ОТБР(t3i /60)+0,01*t3i)-ОТБР(tsi+0,4*ОТБР(t3i/60)+0,01*t3i))>=0,6;(tsi+0,4*ОТБР(t3i /60)+0,01*t3i)+0,4;tsii/60)+0,01*t3i));+0,4*ОТБР(t3 tci=(ЕСЛИ((tfi–t3i)-ОТБР(tfi–t3i)>=0,6;(tfi–t3i)-0,4;(tfi–t3i)));
tri=ЕСЛИ((tsi-tfi-1)>0;ЕСЛИ((tsi-tfi-1)>=0,6;( tsi-tfi-1)-0,4;( tsi-tfi-1));0).
Категория: Имитационное моделирование | Добавил: kvn2us (14.02.2009) | Автор: Кравченко Владимир Николаевич
Просмотров: 3198
Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]